vscode中使用clang+clangd+lldb

在vscode中使用clang+clangd+lldb

安装


1
2
sudo apt install clangd-12 clang-12 clang-format-12
# sudo apt install lldb-12

vscode 插件中需安装 clangd, CMake Tools, CodeLLDB

前面装了 clangd-12,在 vscode 并不能正常调用,还需建立 clangd 到 clangd-12 的软链接,这里不用 ln -s ,而是使用 update-alternatives 来管理

1
2
3
4
5
sudo update-alternatives --install /usr/bin/clang clang /usr/bin/clang-12 0 --slave /usr/bin/clangd clangd /usr/bin/clangd-12 --slave /usr/bin/clang++ clang++ /usr/bin/clang++-12 --slave /usr/bin/clang-